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Introduction to and familiarization with circuit 
simulation techniques. 

 

Primary Objectives: 
• To familiarize the user with the SPICE (Simulation Programme with 

Integrated Circuit Emphasis) simulation package. 
• To introduce net list and schematic capture methods of describing a circuit 

using simple passive circuit examples. 
• To briefly introduce various types of analysis and stimuli. 
• To explain why it is sometimes important to use net lists as opposed to 

schematic capture. 

Aims: 
By the end of the first two weeks students should be able to: 

• set up a circuit simulation. 
• draw and carry out simulations of various circuits presented during the 

remainder of the course. 
 

Exercises 
 
Note: In the following exercises you are expected initially to enter the circuit 
description along with its associated stimuli and analysis statements as a textual 
description, that is in net list format. To do this proceed as follows: 
 
Select -> File -> New -> Netlist 
 
Then place the textual circuit description between the Circuit and .end lines 
 
 

Exercise 1.0  Operating point analysis of a potential divider 
 
Note:  SPICE style simulators always perform an operating point, or DC, analysis on 
a circuit before any other analyses are performed.  This analysis calculates the DC 
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bias points within the circuit and is analogous to a real circuit settling at its DC 
operating point when the power is applied.  
The operating points will only be printed if no other analyses are specified or a .OP or 
.AC statement are included in the circuit file.  

1.1 Circuit  and net list entry: 
The circuit shown in the frame below is a simple potential divider.  Before entering 
the circuit description and performing a simulation do the necessary hand calculations 
to evaluate the node voltages and the current through the resistors in the circuit. 
 
Note: Before attempting any simulation it is always good practice to try and do some 
simple hand calculations to evaluate the circuit.  In the case of this example the circuit 
is simple and the user would immediately know if the simulator was misbehaving.  
However, in complex integrated circuits the user may not know how the circuit will 
operate.  In such a case, initial first order approximations are used to gain a “feel” for 
the expected circuit operation, then the calculations are compared with the more 
accurate simulation results. 
   
 
 
Simple Potential divider schematic                             Corresponding net list 
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Schematic with node numbering 
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***** main circuit 
 
* 5Vdc source across nodes 1 and 0  
V1 1  0 DC 5V 
*  1K resistor across nodes 1 and 2 
R1 1  2  1K  
*  1K resistor across nodes 2 and 0 
R2 2  0  1K  
***** End of main circuit 
*Statement to instruct the simulator to 
*perform an operating point analyses.  
.OP 
 
*.PROBE ;Required by other simulators 
 
*.END ;Must always appear 

*(included automatically in 
*this case)  
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1.1.1 Net list entry: 
 
Note: It is not necessary to type in the lines beginning with an *.  These are comment 
lines and are included to improve readability.  However, if you ever have to produce 
complex net lists, it is always a good idea to include some comments to aid your 
memory of the circuit you have analysed. 
 
Enter the above net list (in between the circuit and .END line), investigating how the 
nodes and components of the schematic description map onto the net list description.  
 
Run the simulator engine from the toolbar: 
 
Simulation -> Run 
 
A window should appear if the simulation is successful. 
Add the calculated values to the window by: 
 
Edit -> Edit Plots  
 
A dialogue box should then appear with the available currents or voltages in the left 
hand pane. Click on the right arrow button to transfer the values to the right hand 
pane.  Then click on OK.  The DC operating voltages and currents should be 
displayed. 
 
Note:  The current through the voltage source is stated as –2.5mA.  This is due to the 
current being measured from node 1 to node zero. 
 
After you have run the simulation successfully try changing some of the statements.  
A suggestion would be to try changing the voltage source statement as follows: 
 
V1 1 0 DC 5V >>> T1 1 0 DC 5V 
 
and then re-simulate.  View the messages in the log window.  
Try to insert other single errors and view the results.  
 
 
Notes on net list conventions: 
  

• Node 0;   this is always the reference node for the circuit (i.e. ground). 
• When declaring a voltage or current source or any two terminal devices with 

its connections the positive node of the device is given first. 
• For other notes on syntax and component declaration refer to the additional 

handout and reference texts. 
• With a complex net list it is good idea to include comments.  This is done by 

including a “*” at the start of the line.  Some simulators also accept a “;” at the 
end of a statement (for in line comments). 
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• For a complete net list additional statements may be required by the 
simulator to control operations such as printing and plotting.  When 
using this particular simulator the statements are included automatically. 
If using a different simulator refer to the appropriate manuals and texts.  

    
1.1.2 Schematic capture: 
 
Initially make sure all the windows within the main window are closed. 
 
Then select: 
 
File -> New -> Mixed signal (Xspice circuit) 
 
A schematic window should appear. 
Place the components in the window as they appear in the above schematic. This is 
done as follows: -  
On the toolbar select: 
Devices -> Then the appropriate parts as below: 
   Voltage source 
   Resistor simple 
   Resistor simple 
   Ground 
 
Note: To rotate the component when it is placed, select the component, right click on 
it, and then select the appropriate option. 
 
After the components are placed wire them together using the wiring tool    
Fifth button from the left below the tool bar. 
 
Note: After each wire has been placed, right click to end the individual wire.  When 
all wires are complete return to the selection mode by clicking the black arrow next to 
the wiring tool button. 
 
 
After the wiring is complete set the component parameters by double clicking on 
them.  Set the parameters as follows: 
 
Voltage source -> Select the radio button Constant (use DC value) and set the DC 
value above it to 5. 
 
Resistors ->   Set the Resistance value to 1k. 
 
Simulation 
 
To run the operating point simulation proceed as follows: 
From the toolbar select: 
Simulation -> Setup Simulations -> In the dialogue box click the .OP checkbox. 
Then select the Run Now button.    
 
The circuit should simulate as in the previous example. 
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If it does not simulate view any messages in the log window and check the circuit 
before re-simulating. 
 
Save the circuit for your reference as: SchemWeek_1_1 
 

1.2 Creating a Net list from the schematic:  
To create net lists from a schematic perform the following steps. 
From the tool bar select: 
 
File -> Create net list document. 
 
A text window should appear with a SPICE net list corresponding to the circuit you 
have just entered.  Study the net list and compare it with the one you entered 
manually, it should be very similar. 
 
Save the circuit for your reference as:  NetWeek_1_1 
 
Notes on net list generation: 
 

• The generated net lists include the line .OPTIONS with various parameters. 
The parameters specify the convergence parameters for the simulator.  These 
modifiers control how well the simulator can produce a solution at each 
calculation point.  For the course we will try to keep the default values. 
However, convergence problems are something you should be aware of if you 
have to carry out any complex simulations. 

• The options statement can include other parameters not related to 
convergence. 

• Why bother with net lists when you have got schematic capture: 
o A SPICE style net list is the common form of interface between a 

schematic capture package and the simulation engine. 
o If you have produced a circuit net list for one circuit, you should be 

able to (with perhaps some modification) simulate it with another 
simulator. 

o If you have a description at the net list level it is possible to write 
programs (in C, Perl, etc.) to modify the net list.  This can be useful for 
more advanced forms of analyses and simulations, such as fault 
injection etc. 

o It is always useful to be able to understand a net list.  Sometimes the 
schematic capture does not work as expected and produces “bad” net 
lists. 

1.3 Extra Work: 
Try to familiarize yourselves with the simulation and capture oriented options 
available in the simulation package.  Before next week try to carry out two tutorials 
that are included in the package. 
 
These are found as follows: 
 
Select help -> Help contents -> Tutorials. 
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And try to work through: 
 
Analog Tutorial #1  and Analog Tutorial #2 
 

Week 2 

2.0  Analysis of a simple RC passive network: 
For this exercise you are expected to enter the circuit using skills and techniques 
obtained in the last exercise 

2.1 Circuit and net list description: 

 
 
 
Circuit equations for the simple low-pass RC network: 
The simple equations for modeling the RC network in the time and frequency domain 
are given below. 
Time domain (Transient and steady state): 
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where the RC product is the time constant of the circuit. 
Note: Vout reaches approx. 99% of Vin in 5 time constants. 
 

Frequency domain: 
Transfer function:      Phase difference:  

Circuit schematic         Netlist 
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***** main circuit 
*Input source * Change 
*accordingly (see text) 
V1 1  0 DC 1 
R1 1  Vout  1K 
C1 Vout  0  1u 
 
*Analysis type *Change 
*accordingly (see text) 
.dc V1 0 5 .1  
 
.end 
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Where ωc is the cutoff frequency (see below) 
 
 
 
The 3dB point,  breakpoint or cutoff frequency: 
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2.1.1 Net list entry: 
 
Enter the net list shown above. (Note it is not necessary to include the comment lines) 
 
2.1.1.1 DC sweep analysis: 
 
Make a note of the: 
 
Independent voltage source line:  V1 1 0 DC 1 
 
which specifies a DC voltage source (called V1) across nodes 1 and 0 with a value of 
1 volt, 
 
and the analysis directive line: .DC V1  0 5 0.1 
 
which informs the simulator to evaluate circuit operation using a DC sweep.  The 
sweep is carried out on the voltage source V1 which starts from 0 volts and ends at 5 
volts.  The resolution of the ramp is 0.1 volts  (i.e. the input V1 is swept from 0 to 5 
volts in 0.1 volt increments). 
 
Run the simulation and observe the output.  
 
As the capacitor is open circuit to DC the output voltage is the same as the input 
voltage. 
 
2.1.1.2 Step Response of low pass RC network: 
 
Change the independent voltage source line to: 
 
V1 1 0 PWL (0 0   1m 0    1.01m 1   10m 1) 
 
Note:  This line specifies an input source changing from 0 to 1 volt at 1ms and 
holding this value for 10ms. The time for the 0 to 1V transition is 10us. 
The stimulus is called a Piecewise Linear Source (PWL) 
See the additional handouts for a more detailed description. 
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Change the analysis directive line to: 
 
.TRAN   10u 10m 0 1u uic 
 
Note: this directive informs the simulator to perform a simulation from 0 to 10ms 
See the additional handout for a more detailed description of the transient analysis 
statement. 
 
Before running the simulations calculate how long it should take for vOUT to reach 
99% of vIN after vIN  is stepped from 0 to 1 volt. 
 
Run the simulation and add V1 and vOUt to the Plots window as follows: 
 
Edit -> Edit Plots -> Select Plots (LH panel) -> Right Arrow -> OK 
 
The graphs of the input and the output voltage should now be displayed in the same 
plot window. 
 
Check that the calculations carried out above match with the graphical output of the 
simulator. 
 
2.1.1.3 Sinusoidal Response of low Pass RC Network: 
 
Change the independent voltage source line to: 
 
V1 1 0 SIN(0 1 20 0 0) 
 
Note: This line specifies a sinusoidal input source of 1 volt amplitude with a 
frequency repetition of  20Hz . 
See the additional handouts for a more detailed description. 
 
 
 
Change the analysis directive line to: 
 
.TRAN  10u 50m 0 1u uic 
 
Note: this directive informs the simulator to perform a simulation from 0 to 50ms 
See the additional handout for a more detailed description of the transient analysis 
statement. 
Note : The 50ms duration  is to allow one cycle of the input and output waveforms to 
be observed. 
 
 
Run the simulation and view the graphs of the input and the output on the same plot. 
 
Investigate the output graphs. 
 
Note any phase and magnitude differences between vOUT and vIN. 
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Now calculate the 3dB frequency of the RC network and the phase lag that vOUT 
should have at this frequency. 
 
Set up the sinusoidal input to have this frequency.  
Note for these purposes you only have to be accurate to within 1Hz  
 
Now change the transient analysis statement so that you can view the output 
waveforms over 1 cycle 
 
Run the simulation and view the output waveforms. 
Note any phase and magnitude differences between vOUT and vIN and check if they 
match up with your calculations. 
 
2.1.1.4 AC (Frequency analysis) of Simple Low Pass RC Network: 
 
Change the independent voltage source line to: 
 
V1 1 0 AC 1 
 
Note: This specifies an AC voltage source of 1 volt magnitude connected between 
nodes 1 and 0. 
 
 
Change the analysis directive line to: 
 
.AC dec 20 100 500 
 
Note: This directive informs the simulator to run a frequency sweep analysis. The AC 
source is swept from 100Hz to 500Hz with 20 points being calculated per decade 
increase in frequency. 
See the additional handouts for more information on the .AC statement. 
 
 
Magnitude verses frequency plot: 
Run the simulation and add the magnitude plot of V(vout) as follows: 
 
Edit -> Edit Plots -> Make sure V(vout) is selected in the left hand panel -> Click 
the “MAG” button -> VM(vout) appears in the right panel -> Click OK. 
 
The plot of vOUt magnitude against frequency should appear in the plot window. 
 
Observe the plot and check it against your calculations in the previous section. 
 
Phase verses frequency plot: 
Remove the previous trace as follows: 
 
Edit -> Edit Plots -> Select VM(vout) in the right panel -> Click on the Left arrow 
button . 
 
Now add the phase trace as follows: 
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Make sure V(vout) is selected in the left hand panel -> Click on (PH_deg) -> Click 
on  OK. 
 
The plot of vOUT phase against frequency should appear in the plot window. 
 
Observe the plot and check it against your calculations in the previous section. 
 
 
2.1.2 Schematic Entry: 
 
Open a new schematic window and enter the circuit from the previous section. 
 
Set up the values for the passive components. 
 
Note: The diamond shaped symbol (Vout) in the circuit diagram is a  marker. This can 
be found in: 
Devices -> Marker. 
Set the parameters as follows: 
Double click on the symbol-> Change the part title to Vout-> Select the Checkbox  
Voltage probe -> Click on OK. 
 
 
 
2.1.2.1 Step response of low pass RC network 
 
Double click on the voltage source 
Select the radio button Piecewise Linear (Ensure all other options are de selected 
and all fields are clear) 
Click the Transient properties tab 
Click the EDIT TABLE button 
Enter the following values: 
0  0 
1m 0 
1.01m 1 
10m 1 
Then click on OK 
 
To setup the analysis the analysis: 
 
From the toolbar: 
Select simulation -> Set up simulations -> Ensure the Transient and Fourier analysis 
is enabled -> Click on the Transient and Fourier analyses button  
 
A dialogue box should appear. 
Change the values in the text fields as follows: 
Results delay start time  = 0 
Stop time    = 10m 
Linearisation step   = 10u 
Step ceiling    = 1u 
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After entering these values Click on OK 
 
To run the simulation  
From the toolbar: 
Select simulation -> Run simulation 
 
The same results should appear as in the previous exercise.  
Produce a net list for the circuit: 
File -> Create Net list Document 
 
A window should appear with a similar net list to that which was produced manually 
in the previous exercise. 
 
2.1.2.2 Sinusoidal response of a low pass RC network: 
 
Double click on the Voltage source symbol. 
Select the Sinusoidal Radio Button. 
Click on Transient properties. 
Change the frequency setting to 20 
 
Note: To change the frequency-setting highlight the Freq parameter and enter the 
value 20 in the value box above. 
  
 
Set up a transient analysis with the following parameters. 
 
Stop time = 50m 
 
Leave all other parameters the same. 
 
Now try to set up a transient analysis for a sine wave stimulus at the 3dB frequency. 
 
 
2.1.2.3 AC (Frequency response): 
 
Double click on the Voltage source symbol. 
Click on the use AC checkbox 
Change the magnitude to 1V 
 
Note: All the other parameters can be left as they are. 
 
Set up the analysis as follows: 
 
From the toolbar: 
 
Select -> Simulations -> Set up simulations -> Select the checkbox .AC (AC 
frequency sweep) make sure all other check boxes are disabled -> Click the button 
.AC (AC frequency sweep) -> Set up the parameters as below: 
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Start Value     = 10 
Stop Value     = 500 
Number of steps per interval = 20 
Stepping interval    = Decade 
 
Click the radio button “Use Magnitude Plots”. 
 
Now run the simulation and view the magnitude and phase plots of vOUT separately. 
The results should correspond to the exercise you carried out for net list entry. 
Create a net list document and investigate it. 
 
Note: You will notice on the voltage source line (V1) that various parameters for the 
source exist. The parameters that are used during simulation depend on the type of 
analysis being carried out.  
  

 


